Disable controller detection

Just Cause 3 Mods Forums Mod Requests Disable controller detection

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #163650
    Drifttk9
    Participant

    I just need a simple script to keep the game from seeing my attached game pad. I dont like the default configuration and since the game doesnt let you change it, I would like to use Xpadder to make my own profile.

     

    I edited the keymap.txt file and removed all the gamepad bindings. it doesnt remove the start and select/back bindings for some reason but its no big deal. Thanks FINDarkside for your help!

    #163651
    revdirty
    Participant

    A better solution is using x360ce. its worked wonders for me , since i can invert the right stick but keep my mouse normal..

    #163654
    chokladchoklad
    Participant

    Um you can change the controls for the game by modding them. Let me know what you want the controls to be and I could do it for you.

    #163660
    FINDarkside
    Participant

    There’s a text file in [username]/documents/square enix/just cause 3 that contains your control settings, you can set them for whatever you wan’t from there. However I don’t understand how making the game not detect your controller would help anything.

    #163664
    Drifttk9
    Participant

    Ok I can check out editing it. It would be awesome if I can edit all the buttons to do nothing.

     

    Disabling controller detection allows me to use xpadder profiles instead. Xpadder treats the input device as a mouse and keyboard. So even if a game doesn’t have support for a controller I can play that game with one anyway.

    Most games have a way to toggle controllers on and off. this game and some others do not. If the controllers are not turned off in game then when I push the button on the controller both the xpadder function and the native control function will be sent.

    Last thing I want is to grapple and throw grenade at the same time.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.